Exchange 2016 CU 19

Sunday 21st February 2021 05:00 AM

Purpose: In an effort to be within Microsoft recommended guidelines of N-1 for Exchange 2016 versions we need to upgrade our environment from CU 18 to CU 19.

Impact: LOW

Affected: Exchange On-Prem

Posted On: Thursday 14th January 2021 08:49 AM